Forms submit button not working? – HTML & CSS – SitePoint

I have

<!DOCTYPE html>
<html lang="en">
<head>
<meta http-equiv="refresh" content="1800; url=../login/logout.php" /><title>Edit Power Strip</title>
<link rel="stylesheet" type="text/css" href="../css/bootstrap.min.css">
<link rel="stylesheet" href="../css/font-awesome.min.css" type="text/css" />
<link rel="stylesheet" type="text/css" href="../css/tabs.css">
<link rel="stylesheet" href="../css/style.css" type="text/css" />
<link href='../css/select2.min.css' rel='stylesheet' type='text/css' />
<style>
img.type {
margin-right:15px;
display: inline-block;
width:40px;
}
.tab label {
order: 0;
display: block;
padding:0;
margin: 0;
background: none;
color: #000;
border: none;
transition: none;
}
li.select2-results__option:hover { background-color:#ddd; }
.select2-container { width: 461.77px !important; }
small { font-size:60% }
</style>
</head>
<body>
<nav class="navbar navbar-expand-lg navbar-dark bg-dark" style="margin-bottom:10px">
<a class="navbar-brand mb-2" href="../index.php">Data Collection Tool</a>
<p class="text-white position-absolute font-weight-bold font-italic" style="top:35px">Beta</p>
<button class="navbar-toggler" type="button" data-toggle="collapse" data-target="#navbarSupportedContent" aria-controls="navbarSupportedContent" aria-expanded="false" aria-label="Toggle navigation">
<span class="navbar-toggler-icon"></span>
</button>

<div class="collapse navbar-collapse" id="navbarSupportedContent">
<ul class="navbar-nav mr-auto">
<li class="nav-item">
<a class="nav-link" href="../index.php">Home</a>
</li>
<li class="nav-item">
<a class="nav-link" href="../rooms/comms.php">Comms&nbsp;Room</a>
</li>
<li class="nav-item">
<a class="nav-link" href="../rooms/crypto.php">Crypto&nbsp;Room</a>
</li>
<li class="nav-item">
<a class="nav-link" href="../rooms/data.php">Data&nbsp;Center</a>
</li>
<li class="nav-item">
<a class="nav-link" href="../rooms/server.php">Server&nbsp;Room</a>
</li>
<li class="nav-item">
<a class="nav-link" href="../rooms/tech.php">Tech&nbsp;Control</a>
</li>
<li class="nav-item">
<a class="nav-link" href="../rooms/watch.php">Watch&nbsp;Floor</a>
</li>

</ul>
<span class="navbar-text">
You&nbsp;are&nbsp;logged&nbsp;in&nbsp;as&nbsp;&nbsp;[email protected]&nbsp;&nbsp;<a class="btn btn-danger btn-sm" href="../login/logout.php" role="button">Logout</a> </span>
</div>
</nav>
<div class="card" style="margin:25px auto; width:85%">
<div class="card-header">
<h2 style="display:inline"><img src="../images/edit_power_strip_icon.png" alt="Power">&nbsp;&nbsp;Edit Power Strip</h2>
</div>
<div class="card-body p-3">
<form method="post" action="edit_power_strip_engine.php">
<div class="row">
<div class="col">
<div class="alert alert-light shadow" role="alert">
<div class="row">
<div class="col">
<label for="name">Name (Optional)</label>
<input type="text" class="form-control" id="name" name="Name" maxlength="50" value="">
</div>
</div>
<div class="row mt-3">
<div class="col">
<label for="Manufacturer">Manufacturer:</label>
<div .......

Source: https://www.sitepoint.com/community/t/forms-submit-button-not-working/385133

Posted on

Leave a Reply

Your email address will not be published. Required fields are marked *